Intermittent Direct Billing Issue: Vodafone
Incident Report for Fonix Services
Resolved
This incident has been resolved.
Posted Sep 15, 2017 - 11:37 BST
Investigating
Dear Customer

Please be advised Vodafone are currently experiencing intermittent issues on their Direct Billing platform. We have raised it into them and they are investigating.

We will update you as soon as we have any further information.

Kind regards,

Fonix Operations Team
Posted Sep 12, 2017 - 17:50 BST
This incident affected: Direct Billing.