Direct Billing Issue: O2
Incident Report for Fonix Services
Resolved
Dear Customer,

the issue has been resolved and requests are processed successfully since 00:13.

Kind regards,

Fonix Operations Team
Posted Jan 26, 2020 - 00:40 GMT
Investigating
Dear Customer

Please be advised O2 are currently experiencing issues on their Direct Billing platform. We have raised it into them and they are investigating.

We will update you as soon as we have any further information.

Kind regards,

Fonix Operations Team
Posted Jan 26, 2020 - 00:04 GMT
This incident affected: Direct Billing.