Three Billing Issue
Incident Report for Fonix Services
Resolved
Dear Customer

Three have confirmed the issue was resolved at 22.57.

We have no further details at this time but will update you if we receive any additional information.

Kind regards

Fonix Operations Team
Posted Mar 24, 2017 - 06:04 GMT
Identified
Dear Customer

Please be advised we have received a notification from Three regarding a current service degradation impacting billing services.

They are investigating as a high priority and will provide an update as soon as possible.

Kind regards

Fonix Operations Team
Posted Mar 23, 2017 - 22:19 GMT
This incident affected: Mobile Operator Connections (Three-UK).