EE - Direct Billing and Digital Identity - Intermittent Issues

Incident Report for Fonix Services

Resolved

This incident has now been restored, as of 27/05/2026 11:31:45 BST.
Posted May 27, 2026 - 14:05 BST

Monitoring

Dear Customer

Please be advised EE is experiencing intermittent issues impacting their Direct Billing & Digital Identity services since approximately 10:43am.

Recovery has been observed. Early signs of service improvement are being seen, with teams reporting traffic beginning to normalise and affected applications starting to clear.

EE continue to monitor closely while the underlying cause is confirmed and we will update as soon as we know more.

Kind Regards,
Posted May 27, 2026 - 12:20 BST
This incident affected: Direct Billing and Operator Age Verification.