Intermittent Direct Billing Issue: Three
Incident Report for Fonix Services
Resolved
This incident has been resolved.
Posted Oct 17, 2019 - 09:30 BST
Identified
Dear Customer

Please be advised Three are currently experiencing intermittent issues on their Direct Billing platform. We have raised it into them and they are investigating.

We will update you as soon as we have any further information.

Kind regards,

Fonix Operations Team
Posted Oct 17, 2019 - 01:38 BST
This incident affected: Direct Billing.